How can I upgrade my OSN package?